import re
regex = re.compile(r"[A-Za-z]+(?= ?:\[\(h\d+\){h\d+}])")
test_str = ("Taxi:[(h19){h12}], HeavyTruck :[(h19){h12}]\n\n\n\n"
"Taxi:[(h19){h12}], HeavyTruck :[(h19){h12}\n"
"Taxi:[(h19){h12}, HeavyTruck :[(h19){h12}]\n"
"Taxi:[(h19){12}], HeavyTruck [(h19){h12}]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")