package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<b.*?>(.*?)<\/b>`)
var str = `Your <b class =\"b_1\">1</b> payment due is $4000.Your <b class =\"b_1\">2</b> payment due is $3500. Your <b class =\"b_1\">3</b> payment due is $5000.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}