re = /<b.*?>(.*?)<\/b>/
str = 'Your <b class =\\"b_1\\">1</b> payment due is $4000.Your <b class =\\"b_1\\">2</b> payment due is $3500. Your <b class =\\"b_1\\">3</b> payment due is $5000.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end