import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<b.*?>(.*?)<\\/b>";
final String string = "Your <b class =\\\"b_1\\\">1</b> payment due is $4000.Your <b class =\\\"b_1\\\">2</b> payment due is $3500. Your <b class =\\\"b_1\\\">3</b> payment due is $5000.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}