use strict;
my $str = 'Your <b class =\\"b_1\\">1</b> payment due is $4000.Your <b class =\\"b_1\\">2</b> payment due is $3500. Your <b class =\\"b_1\\">3</b> payment due is $5000.';
my $regex = qr/<b.*?>(.*?)<\/b>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}