# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*)£(.*)/$2/gm;t' <<< "jon52_rs - £5
caneflagi - £5
Tehhguam - £5
Clapu - £5-05"