// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*)£(.*)").unwrap();
let string = "jon52_rs - £5
caneflagi - £5
Tehhguam - £5
Clapu - £5-05";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}