#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*)£(.*)"
Local $sString = "jon52_rs - £5 " & @CRLF & _
"caneflagi - £5 " & @CRLF & _
"Tehhguam - £5 " & @CRLF & _
"Clapu - £5-05"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)