package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)£(.*)`)
var str = `jon52_rs - £5
caneflagi - £5
Tehhguam - £5
Clapu - £5-05`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}