import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)£(.*)";
final String string = "jon52_rs - £5 \n"
+ "caneflagi - £5 \n"
+ "Tehhguam - £5 \n"
+ "Clapu - £5-05";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}