using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/backbone.js";
string input = @"dfjSKsfkfkSFKfdvsfdvsdv https://text.com from fgfg https://test27.com fgfgfgfg https://test2.com dhsdhsadasj sdjgdsdh https://backbone.js from jfsjfskf https://backbone.js jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com sfgsfsfggf https://backbone.js";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}