const regex = /https:\/\/backbone.js/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/backbone.js', 'i')
const str = `dfjSKsfkfkSFKfdvsfdvsdv https://text.com from fgfg https://test27.com fgfgfgfg https://test2.com dhsdhsadasj sdjgdsdh https://backbone.js from jfsjfskf https://backbone.js jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com sfgsfsfggf https://backbone.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}