$re = '/https:\/\/backbone.js/i';
$str = 'dfjSKsfkfkSFKfdvsfdvsdv https://text.com from fgfg https://test27.com fgfgfgfg https://test2.com dhsdhsadasj sdjgdsdh https://backbone.js from jfsjfskf https://backbone.js jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com sfgsfsfggf https://backbone.js';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);