re = /https:\/\/backbone.js/i
str = 'dfjSKsfkfkSFKfdvsfdvsdv https://text.com from fgfg https://test27.com fgfgfgfg https://test2.com dhsdhsadasj sdjgdsdh https://backbone.js from jfsjfskf https://backbone.js jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com sfgsfsfggf https://backbone.js'
# Print the match result
str.match(re) do |match|
puts match.to_s
end