package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)https:\/\/backbone.js`)
var str = `dfjSKsfkfkSFKfdvsfdvsdv https://text.com from fgfg https://test27.com fgfgfgfg https://test2.com dhsdhsadasj sdjgdsdh https://backbone.js from jfsjfskf https://backbone.js jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com sfgsfsfggf https://backbone.js`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}