using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^6(?:9\d{7}|5[5-9]\d{6})$";
string input = @"# Invalid
61234
6123456789
6word7890
12688684749
# MTN
688684749
678684749
651684749
652684749
653684749
654684749
# Orange
698684749
655684749
656684749
657684749
658684749";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}