use strict;
my $str = '# Invalid
61234
6123456789
6word7890
12688684749
# MTN
688684749
678684749
651684749
652684749
653684749
654684749
# Orange
698684749
655684749
656684749
657684749
658684749';
my $regex = qr/^6(?:9\d{7}|5[5-9]\d{6})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}