// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^6(?:9\d{7}|5[5-9]\d{6})$").unwrap();
let string = "# Invalid
61234
6123456789
6word7890
12688684749
# MTN
688684749
678684749
651684749
652684749
653684749
654684749
# Orange
698684749
655684749
656684749
657684749
658684749";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}