import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^6(?:9\\d{7}|5[5-9]\\d{6})$";
final String string = "# Invalid\n\n"
+ "61234\n"
+ "6123456789\n"
+ "6word7890\n\n"
+ "12688684749\n\n"
+ "# MTN\n"
+ "688684749\n"
+ "678684749\n"
+ "651684749\n"
+ "652684749\n"
+ "653684749\n"
+ "654684749\n\n"
+ "# Orange\n\n"
+ "698684749\n"
+ "655684749\n"
+ "656684749\n"
+ "657684749\n"
+ "658684749";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}