package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^6(?:9\d{7}|5[5-9]\d{6})$`)
var str = `# Invalid
61234
6123456789
6word7890
12688684749
# MTN
688684749
678684749
651684749
652684749
653684749
654684749
# Orange
698684749
655684749
656684749
657684749
658684749`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}