using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td width=""\d+%"" class=""listhdrr""><\?=gettext\(""(.+)""\)\;\?><\/td>";
string substitution = @"<th>$1</th>";
string input = @"<td width=""17%"" class=""listhdrr""><?=gettext(""SOME TEXT"");?></td>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}