import re
regex = re.compile(r"<td width=\"\d+%\" class=\"listhdrr\"><\?=gettext\(\"(.+)\"\)\;\?><\/td>")
test_str = "<td width=\"17%\" class=\"listhdrr\"><?=gettext(\"SOME TEXT\");?></td>"
subst = "<th>$1</th>"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)