import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td width=\"\\d+%\" class=\"listhdrr\"><\\?=gettext\\(\"(.+)\"\\)\\;\\?><\\/td>";
final String string = "<td width=\"17%\" class=\"listhdrr\"><?=gettext(\"SOME TEXT\");?></td>";
final String subst = "<th>$1</th>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}