// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<td width="\d+%" class="listhdrr"><\?=gettext\("(.+)"\)\;\?><\/td>"#).unwrap();
let string = "<td width=\"17%\" class=\"listhdrr\"><?=gettext(\"SOME TEXT\");?></td>";
let substitution = "<th>$1</th>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}