$re = '/<td width="\d+%" class="listhdrr"><\?=gettext\("(.+)"\)\;\?><\/td>/';
$str = '<td width="17%" class="listhdrr"><?=gettext("SOME TEXT");?></td>';
$subst = "<th>$1</th>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;