#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?>(\w+) (?=\1\b))+"
Local $sString = "dog dog dog cat cat fish"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)