import Foundation
let pattern = #"(?>(\w+) (?=\1\b))+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"dog dog dog cat cat fish"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)