using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?>(\w+) (?=\1\b))+";
string substitution = @"";
string input = @"dog dog dog cat cat fish";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}