re = /(?>(\w+) (?=\1\b))+/
str = 'dog dog dog cat cat fish'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result