const regex = /(?>(\w+) (?=\1\b))+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?>(\\w+) (?=\\1\\b))+', 'g')
const str = `dog dog dog cat cat fish`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);