package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)\^(?:\d+\^)*a`)
var str = `1^1^4~3^4^2~4^9^a
4^2^2~8^9^a~1^1^1 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}