const regex = /(\d+)\^(?:\d+\^)*a/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\^(?:\\d+\\^)*a', 'g')
const str = `1^1^4~3^4^2~4^9^a
4^2^2~8^9^a~1^1^1 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}