// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+)\^(?:\d+\^)*a").unwrap();
let string = "1^1^4~3^4^2~4^9^a
4^2^2~8^9^a~1^1^1 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}