$re = '/(\d+)\^(?:\d+\^)*a/';
$str = '1^1^4~3^4^2~4^9^a
4^2^2~8^9^a~1^1^1 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);