#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "meowmeow"
Local $sString = " [36]=>" & @CRLF & _
" object(Cloud)#37 (3) {" & @CRLF & _
" ["members"]=>" & @CRLF & _
" array(27) {" & @CRLF & _
" [0]=>" & @CRLF & _
" array(5) {" & @CRLF & _
" ["X"]=>" & @CRLF & _
" string(4) "2313"" & @CRLF & _
" ["Y"]=>" & @CRLF & _
" string(4) "1139"" & @CRLF & _
" ["creator"]=>" & @CRLF & _
" string(14) "CanavanKingBio"" & @CRLF & _
" ["griefer"]=>" & @CRLF & _
" string(17) "PL45M4 D3V45T4T0R"" & @CRLF & _
" ["g_time"]=>" & @CRLF & _
" string(8) "15313856"" & @CRLF & _
" }" & @CRLF & _
" [1]=>" & @CRLF & _
" array(5) {" & @CRLF & _
" ["X"]=>" & @CRLF & _
" string(4) "2313"" & @CRLF & _
" ["Y"]=>" & @CRLF & _
" string(4) "1140"" & @CRLF & _
" ["creator"]=>" & @CRLF & _
" string(14) "CanavanKingBio"" & @CRLF & _
" ["griefer"]=>" & @CRLF & _
" string(17) "PL45M4 D3V45T4T0R"" & @CRLF & _
" ["g_time"]=>" & @CRLF & _
" string(8) "15313856"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" ["size"]=>" & @CRLF & _
" int(27)" & @CRLF & _
" ["merge"]=>" & @CRLF & _
" array(1) {" & @CRLF & _
" [0]=>" & @CRLF & _
" int(40)" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")