import Foundation
let pattern = #"meowmeow"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
[36]=>
object(Cloud)#37 (3) {
["members"]=>
array(27) {
[0]=>
array(5) {
["X"]=>
string(4) "2313"
["Y"]=>
string(4) "1139"
["creator"]=>
string(14) "CanavanKingBio"
["griefer"]=>
string(17) "PL45M4 D3V45T4T0R"
["g_time"]=>
string(8) "15313856"
}
[1]=>
array(5) {
["X"]=>
string(4) "2313"
["Y"]=>
string(4) "1140"
["creator"]=>
string(14) "CanavanKingBio"
["griefer"]=>
string(17) "PL45M4 D3V45T4T0R"
["g_time"]=>
string(8) "15313856"
}
}
["size"]=>
int(27)
["merge"]=>
array(1) {
[0]=>
int(40)
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}