const regex = /meowmeow/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('meowmeow', '')
const str = ` [36]=>
object(Cloud)#37 (3) {
["members"]=>
array(27) {
[0]=>
array(5) {
["X"]=>
string(4) "2313"
["Y"]=>
string(4) "1139"
["creator"]=>
string(14) "CanavanKingBio"
["griefer"]=>
string(17) "PL45M4 D3V45T4T0R"
["g_time"]=>
string(8) "15313856"
}
[1]=>
array(5) {
["X"]=>
string(4) "2313"
["Y"]=>
string(4) "1140"
["creator"]=>
string(14) "CanavanKingBio"
["griefer"]=>
string(17) "PL45M4 D3V45T4T0R"
["g_time"]=>
string(8) "15313856"
}
}
["size"]=>
int(27)
["merge"]=>
array(1) {
[0]=>
int(40)
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}