use strict;
my $str = ' [36]=>
object(Cloud)#37 (3) {
["members"]=>
array(27) {
[0]=>
array(5) {
["X"]=>
string(4) "2313"
["Y"]=>
string(4) "1139"
["creator"]=>
string(14) "CanavanKingBio"
["griefer"]=>
string(17) "PL45M4 D3V45T4T0R"
["g_time"]=>
string(8) "15313856"
}
[1]=>
array(5) {
["X"]=>
string(4) "2313"
["Y"]=>
string(4) "1140"
["creator"]=>
string(14) "CanavanKingBio"
["griefer"]=>
string(17) "PL45M4 D3V45T4T0R"
["g_time"]=>
string(8) "15313856"
}
}
["size"]=>
int(27)
["merge"]=>
array(1) {
[0]=>
int(40)
}';
my $regex = qr/meowmeow/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}