package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(.*)_([12]?\d{1,2}\.){3}[12]?\d{1,2}_\d+\.([a-z]{3,4})$`)
var str = []byte(`pdf_of_filename_53613785621.183761237_127.10.10.0_8726347.xls`)
var substitution = []byte("\1.\3")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}