const regex = /^(.*)_([12]?\d{1,2}\.){3}[12]?\d{1,2}_\d+\.([a-z]{3,4})$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)_([12]?\\d{1,2}\\.){3}[12]?\\d{1,2}_\\d+\\.([a-z]{3,4})$', 'i')
const str = `pdf_of_filename_53613785621.183761237_127.10.10.0_8726347.xls`;
const subst = `\1.\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);