// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^(.*)_([12]?\d{1,2}\.){3}[12]?\d{1,2}_\d+\.([a-z]{3,4})$").unwrap();
let string = "pdf_of_filename_53613785621.183761237_127.10.10.0_8726347.xls";
let substitution = "\\1.\\3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}