re = /^(.*)_([12]?\d{1,2}\.){3}[12]?\d{1,2}_\d+\.([a-z]{3,4})$/i
str = 'pdf_of_filename_53613785621.183761237_127.10.10.0_8726347.xls'
subst = '\\1.\\3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result