# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([0-9] )/0\1/gm;t' <<< "6 September 2013
13 Mars 2014
20 Mars 2012"