$re = '/^([0-9] )/m';
$str = '6 September 2013
13 Mars 2014
20 Mars 2012';
$subst = "0\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;