#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([0-9] )"
Local $sString = "6 September 2013" & @CRLF & _
"13 Mars 2014" & @CRLF & _
"20 Mars 2012"
Local $sSubst = "0\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)