// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9] )").unwrap();
let string = "6 September 2013
13 Mars 2014
20 Mars 2012";
let substitution = "0\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}