re = /^([0-9] )/m
str = '6 September 2013
13 Mars 2014
20 Mars 2012'
subst = '0\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result