using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^u]es|ma$|mo|y|[mie]e|wi|ter|au";
string input = @"mother
mom
ma
daughter
sister
wife
grandmother
grandma
aunt
niece
queen
princess
empress
duchess
marchioness
countess
baroness
baronetess
lady
dame
father
dad
pa
son
brother
husband
grandfather
grandpa
uncle
nephew
king
prince
emperor
duke
marquess
earl
baron
baronet
lord
knight";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}