use strict;
my $str = 'mother
mom
ma
daughter
sister
wife
grandmother
grandma
aunt
niece
queen
princess
empress
duchess
marchioness
countess
baroness
baronetess
lady
dame
father
dad
pa
son
brother
husband
grandfather
grandpa
uncle
nephew
king
prince
emperor
duke
marquess
earl
baron
baronet
lord
knight';
my $regex = qr/[^u]es|ma$|mo|y|[mie]e|wi|ter|au/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}