// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^u]es|ma$|mo|y|[mie]e|wi|ter|au").unwrap();
let string = "mother
mom
ma
daughter
sister
wife
grandmother
grandma
aunt
niece
queen
princess
empress
duchess
marchioness
countess
baroness
baronetess
lady
dame
father
dad
pa
son
brother
husband
grandfather
grandpa
uncle
nephew
king
prince
emperor
duke
marquess
earl
baron
baronet
lord
knight";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}